const regex = /^source\.(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^source\\.(.+)$', 'gm')
const str = `source.organizations
source.departments
source.employees`;
const subst = `EXTERNAL_\U$1\E`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);