$re = '/^source\.(.+)$/m';
$str = 'source.organizations
source.departments
source.employees';
$subst = "EXTERNAL_\U$1\E";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;