// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^source\.(.+)$").unwrap();
let string = "source.organizations
source.departments
source.employees";
let substitution = "EXTERNAL_\\U$1\\E";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}