import re
regex = re.compile(r"^source\.(.+)$", flags=re.MULTILINE)
test_str = ("source.organizations\n"
"source.departments\n"
"source.employees")
subst = "EXTERNAL_\\U$1\\E"
result = regex.sub(subst, test_str)
if result:
print(result)