#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/scan\/anything\/se=([\w-.]+)\/se=((?:[\w-.]+)(?=\.html)|[\w-.]+)"
Local $sString = "/scan/anything/se=hello-world/se=word.html" & @CRLF & _
"/scan/anything/se=hello-world.html/se=word.html" & @CRLF & _
"/scan/anything/se=hello-world/se=1.5/" & @CRLF & _
"/scan/anything/se=hello-world/se=1.5" & @CRLF & _
"/scan/anything/se=temp-2.5/se=1.5.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")