use strict;
my $str = '/scan/anything/se=hello-world/se=word.html
/scan/anything/se=hello-world.html/se=word.html
/scan/anything/se=hello-world/se=1.5/
/scan/anything/se=hello-world/se=1.5
/scan/anything/se=temp-2.5/se=1.5.html';
my $regex = qr/^\/scan\/anything\/se=([\w-.]+)\/se=((?:[\w-.]+)(?=\.html)|[\w-.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}