import re
regex = re.compile(r"^\/scan\/anything\/se=([\w-.]+)\/se=((?:[\w-.]+)(?=\.html)|[\w-.]+)", flags=re.MULTILINE)
test_str = ("/scan/anything/se=hello-world/se=word.html\n"
"/scan/anything/se=hello-world.html/se=word.html\n"
"/scan/anything/se=hello-world/se=1.5/\n"
"/scan/anything/se=hello-world/se=1.5\n"
"/scan/anything/se=temp-2.5/se=1.5.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")