import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/scan\\/anything\\/se=([\\w-.]+)\\/se=((?:[\\w-.]+)(?=\\.html)|[\\w-.]+)";
final String string = "/scan/anything/se=hello-world/se=word.html\n"
+ "/scan/anything/se=hello-world.html/se=word.html\n"
+ "/scan/anything/se=hello-world/se=1.5/\n"
+ "/scan/anything/se=hello-world/se=1.5\n"
+ "/scan/anything/se=temp-2.5/se=1.5.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}