using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/scan\/anything\/se=([\w-.]+)\/se=((?:[\w-.]+)(?=\.html)|[\w-.]+)";
string input = @"/scan/anything/se=hello-world/se=word.html
/scan/anything/se=hello-world.html/se=word.html
/scan/anything/se=hello-world/se=1.5/
/scan/anything/se=hello-world/se=1.5
/scan/anything/se=temp-2.5/se=1.5.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}