using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$";
string input = @"SM_2020Q1_Vendor_20R1_1.xls";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}