$re = '/^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$/m';
$str = 'SM_2020Q1_Vendor_20R1_1.xls';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);