// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$").unwrap();
let string = "SM_2020Q1_Vendor_20R1_1.xls";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}