package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$`)
var str = `SM_2020Q1_Vendor_20R1_1.xls`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}