re = /^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$/m
str = 'SM_2020Q1_Vendor_20R1_1.xls'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end