const regex = /^SM_\d{4}Q\d_.*?_\d\d[A-Z]\d_\d\.xls$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^SM_\\d{4}Q\\d_.*?_\\d\\d[A-Z]\\d_\\d\\.xls$', 'gm')
const str = `SM_2020Q1_Vendor_20R1_1.xls`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}