#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)@but\.label:\s*'\{i18n>([\w.]+)\}'[\s\S]*?\s((?!AS)[A-Za-z]\w+)"
Local $sString = "@ObjectModel.readOnly: true" & @CRLF & _
" @but.creatable: false" & @CRLF & _
" @but.updatable: false" & @CRLF & _
" @but.label: '{i18n>Attr4.Name}'" & @CRLF & _
" '' as Name: String(80)," & @CRLF & _
"" & @CRLF & _
" @ObjectModel.readOnly: true" & @CRLF & _
" @but.creatable: false" & @CRLF & _
" @but.updatable: false" & @CRLF & _
" @but.label: '{i18n>Asddf.Time}'" & @CRLF & _
" Time," & @CRLF & _
"" & @CRLF & _
" @ObjectModel.readOnly: true" & @CRLF & _
" @but.creatable: false" & @CRLF & _
" @but.updatable: false" & @CRLF & _
" @but.label: '{i18n>asdfdsf.Attr}'" & @CRLF & _
" Prop: String(80)," & @CRLF & _
"" & @CRLF & _
" @ObjectModel.readOnly: true" & @CRLF & _
" @but.creatable: false" & @CRLF & _
" @but.updatable: false" & @CRLF & _
" Another: String(80),"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")