const regex = /@but\.label:\s*'\{i18n>([\w.]+)\}'[\s\S]*?\s((?!AS)[A-Za-z]\w+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@but\\.label:\\s*\'\\{i18n>([\\w.]+)\\}\'[\\s\\S]*?\\s((?!AS)[A-Za-z]\\w+)', 'gmi')
const str = `@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>Attr4.Name}'
'' as Name: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>Asddf.Time}'
Time,
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>asdfdsf.Attr}'
Prop: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
Another: String(80),`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}