use strict;
my $str = '@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>Attr4.Name}\'
\'\' as Name: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>Asddf.Time}\'
Time,
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>asdfdsf.Attr}\'
Prop: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
Another: String(80),';
my $regex = qr/@but\.label:\s*'\{i18n>([\w.]+)\}'[\s\S]*?\s((?!AS)[A-Za-z]\w+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}