using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@but\.label:\s*'\{i18n>([\w.]+)\}'[\s\S]*?\s((?!AS)[A-Za-z]\w+)";
string input = @"@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>Attr4.Name}'
'' as Name: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>Asddf.Time}'
Time,
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: '{i18n>asdfdsf.Attr}'
Prop: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
Another: String(80),";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}