$re = '/@but\.label:\s*\'\{i18n>([\w.]+)\}\'[\s\S]*?\s((?!AS)[A-Za-z]\w+)/mi';
$str = '@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>Attr4.Name}\'
\'\' as Name: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>Asddf.Time}\'
Time,
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
@but.label: \'{i18n>asdfdsf.Attr}\'
Prop: String(80),
@ObjectModel.readOnly: true
@but.creatable: false
@but.updatable: false
Another: String(80),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);