import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@but\\.label:\\s*'\\{i18n>([\\w.]+)\\}'[\\s\\S]*?\\s((?!AS)[A-Za-z]\\w+)";
final String string = "@ObjectModel.readOnly: true\n"
+ " @but.creatable: false\n"
+ " @but.updatable: false\n"
+ " @but.label: '{i18n>Attr4.Name}'\n"
+ " '' as Name: String(80),\n\n"
+ " @ObjectModel.readOnly: true\n"
+ " @but.creatable: false\n"
+ " @but.updatable: false\n"
+ " @but.label: '{i18n>Asddf.Time}'\n"
+ " Time,\n\n"
+ " @ObjectModel.readOnly: true\n"
+ " @but.creatable: false\n"
+ " @but.updatable: false\n"
+ " @but.label: '{i18n>asdfdsf.Attr}'\n"
+ " Prop: String(80),\n\n"
+ " @ObjectModel.readOnly: true\n"
+ " @but.creatable: false\n"
+ " @but.updatable: false\n"
+ " Another: String(80),";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}