# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s).*?(\S+@\S*school\S*\.\S+)|.+/$1\n/gm;t' <<< "xxxxx
xxxxxx abc@newyork.school.com ...xxxxxx
abc@newyork.school.com xxxxxx xxxx
normal@email.com - NOT TO BE SELECTED
bca@school.edu.com ...
cab@adschool.ssd.com.bn xxxxxx
xxxxxx"