// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s).*?(\S+@\S*school\S*\.\S+)|.+").unwrap();
let string = "xxxxx
xxxxxx abc@newyork.school.com ...xxxxxx
abc@newyork.school.com xxxxxx xxxx
normal@email.com - NOT TO BE SELECTED
bca@school.edu.com ...
cab@adschool.ssd.com.bn xxxxxx
xxxxxx";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}