$re = '/(?s).*?(\S+@\S*school\S*\.\S+)|.+/m';
$str = 'xxxxx
xxxxxx abc@newyork.school.com ...xxxxxx
abc@newyork.school.com xxxxxx xxxx
normal@email.com - NOT TO BE SELECTED
bca@school.edu.com ...
cab@adschool.ssd.com.bn xxxxxx
xxxxxx';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;