import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s).*?(\\S+@\\S*school\\S*\\.\\S+)|.+";
final String string = "xxxxx\n"
+ "xxxxxx abc@newyork.school.com ...xxxxxx\n"
+ "abc@newyork.school.com xxxxxx xxxx\n"
+ "normal@email.com - NOT TO BE SELECTED\n"
+ "bca@school.edu.com ...\n\n"
+ "cab@adschool.ssd.com.bn xxxxxx\n"
+ "xxxxxx";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}