#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s).*?(\S+@\S*school\S*\.\S+)|.+"
Local $sString = "xxxxx" & @CRLF & _
"xxxxxx abc@newyork.school.com ...xxxxxx" & @CRLF & _
"abc@newyork.school.com xxxxxx xxxx" & @CRLF & _
"normal@email.com - NOT TO BE SELECTED" & @CRLF & _
"bca@school.edu.com ..." & @CRLF & _
"" & @CRLF & _
"cab@adschool.ssd.com.bn xxxxxx" & @CRLF & _
"xxxxxx"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)