using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s).*?(\S+@\S*school\S*\.\S+)|.+";
string substitution = @"$1\n";
string input = @"xxxxx
xxxxxx abc@newyork.school.com ...xxxxxx
abc@newyork.school.com xxxxxx xxxx
normal@email.com - NOT TO BE SELECTED
bca@school.edu.com ...
cab@adschool.ssd.com.bn xxxxxx
xxxxxx";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}