using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\s*@#](?:BUY|SELL)|(GOLD)";
string input = @"XAUUSD BUY LIMIT@ 1803
XAUUSD SELL @1800
GOLD SELL
XAUUSD BUY@ 1811.3-1810
XAUUSD BUY NOW 1811.2
XAUUSD BUY 1811.3
XAUUSD BUY @ 1811.3
BUY LIMIT @XAUUSD@ 1811.
XAUUSD@BUY 1811.
XAUUSD@ BUY 1811.
XAUUSD @BUY 1811.
BUY LIMIT XAUUSD @1811.3
SELL LIMIT XAUUSD
U//scvxcxSELL XAUUSD
UxxczcSELL GOLD
xauusd buy@321321.23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}