import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\\s*@#](?:BUY|SELL)|(GOLD)";
final String string = "XAUUSD BUY LIMIT@ 1803\n"
+ "XAUUSD SELL @1800\n"
+ "GOLD SELL\n"
+ "XAUUSD BUY@ 1811.3-1810\n"
+ "XAUUSD BUY NOW 1811.2\n"
+ "XAUUSD BUY 1811.3\n"
+ "XAUUSD BUY @ 1811.3\n"
+ "BUY LIMIT @XAUUSD@ 1811.\n"
+ "XAUUSD@BUY 1811.\n"
+ "XAUUSD@ BUY 1811.\n"
+ "XAUUSD @BUY 1811.\n"
+ "BUY LIMIT XAUUSD @1811.3\n"
+ "SELL LIMIT XAUUSD\n"
+ "U//scvxcxSELL XAUUSD\n"
+ "UxxczcSELL GOLD\n"
+ "xauusd buy@321321.23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}