import Foundation
let pattern = ##"(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\s*@#](?:BUY|SELL)|(GOLD)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
XAUUSD BUY LIMIT@ 1803
XAUUSD SELL @1800
GOLD SELL
XAUUSD BUY@ 1811.3-1810
XAUUSD BUY NOW 1811.2
XAUUSD BUY 1811.3
XAUUSD BUY @ 1811.3
BUY LIMIT @XAUUSD@ 1811.
XAUUSD@BUY 1811.
XAUUSD@ BUY 1811.
XAUUSD @BUY 1811.
BUY LIMIT XAUUSD @1811.3
SELL LIMIT XAUUSD
U//scvxcxSELL XAUUSD
UxxczcSELL GOLD
xauusd buy@321321.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)