package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\s*@#](?:BUY|SELL)|(GOLD)`)
var str = `XAUUSD BUY LIMIT@ 1803
XAUUSD SELL @1800
GOLD SELL
XAUUSD BUY@ 1811.3-1810
XAUUSD BUY NOW 1811.2
XAUUSD BUY 1811.3
XAUUSD BUY @ 1811.3
BUY LIMIT @XAUUSD@ 1811.
XAUUSD@BUY 1811.
XAUUSD@ BUY 1811.
XAUUSD @BUY 1811.
BUY LIMIT XAUUSD @1811.3
SELL LIMIT XAUUSD
U//scvxcxSELL XAUUSD
UxxczcSELL GOLD
xauusd buy@321321.23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}