// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:BUY|SELL|LIMIT|STOP)(?:.*?)([A-Z]{6,})|([A-Z(GOLD)]{6,})(?:.*?)[\s*@#](?:BUY|SELL)|(GOLD)").unwrap();
let string = "XAUUSD BUY LIMIT@ 1803
XAUUSD SELL @1800
GOLD SELL
XAUUSD BUY@ 1811.3-1810
XAUUSD BUY NOW 1811.2
XAUUSD BUY 1811.3
XAUUSD BUY @ 1811.3
BUY LIMIT @XAUUSD@ 1811.
XAUUSD@BUY 1811.
XAUUSD@ BUY 1811.
XAUUSD @BUY 1811.
BUY LIMIT XAUUSD @1811.3
SELL LIMIT XAUUSD
U//scvxcxSELL XAUUSD
UxxczcSELL GOLD
xauusd buy@321321.23";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}