import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\\\\"([^\\\"]{27})\\\\\\\"";
final String string = " '[[\\\"jewelry_designer\\\"]\\n,[\\\"watch_store\\\"]\\n,[\\\"jewelry_appraiser\\\"]\\n,[\\\"leather_goods_store\\\"]\\n]\\n,null,\\\"DpIJr_dR-DNu5kcR9RGmRprcnGU\\\",null,null,null,[null]'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}