const regex = new RegExp('\\\\\\"([^\\"]{27})\\\\\\"', 'gm')
const str = ` '[[\\"jewelry_designer\\"]\\n,[\\"watch_store\\"]\\n,[\\"jewelry_appraiser\\"]\\n,[\\"leather_goods_store\\"]\\n]\\n,null,\\"DpIJr_dR-DNu5kcR9RGmRprcnGU\\",null,null,null,[null]'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}