re = /\\\"([^\"]{27})\\\"/m
str = ' \'[[\\"jewelry_designer\\"]\\n,[\\"watch_store\\"]\\n,[\\"jewelry_appraiser\\"]\\n,[\\"leather_goods_store\\"]\\n]\\n,null,\\"DpIJr_dR-DNu5kcR9RGmRprcnGU\\",null,null,null,[null]\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end