import Foundation
let pattern = #"\\\"([^\"]{27})\\\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" '[[\"jewelry_designer\"]\n,[\"watch_store\"]\n,[\"jewelry_appraiser\"]\n,[\"leather_goods_store\"]\n]\n,null,\"DpIJr_dR-DNu5kcR9RGmRprcnGU\",null,null,null,[null]'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)