// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\\\"([^\"]{27})\\\""#).unwrap();
let string = " '[[\\\"jewelry_designer\\\"]\\n,[\\\"watch_store\\\"]\\n,[\\\"jewelry_appraiser\\\"]\\n,[\\\"leather_goods_store\\\"]\\n]\\n,null,\\\"DpIJr_dR-DNu5kcR9RGmRprcnGU\\\",null,null,null,[null]'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}