#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)@[^:]+"
Local $sString = "true-[Test5]procedure4.spec@mohan:180713133712267-1"
Local $sSubst = "@X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)