$re = '/@[^:]+/m';
$str = 'true-[Test5]procedure4.spec@mohan:180713133712267-1';
$subst = "@X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;