const regex = /@[^:]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@[^:]+', 'gm')
const str = `true-[Test5]procedure4.spec@mohan:180713133712267-1`;
const subst = `@X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);