// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@[^:]+").unwrap();
let string = "true-[Test5]procedure4.spec@mohan:180713133712267-1";
let substitution = "@X";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}