use strict;
my $str = 'true-[Test5]procedure4.spec@mohan:180713133712267-1';
my $regex = qr/@[^:]+/mp;
my $subst = '@X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";