re = /@[^:]+/m
str = 'true-[Test5]procedure4.spec@mohan:180713133712267-1'
subst = '@X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result