package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ # Start of line
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
:(?!=) # Colon NOT followed by an equal-sign
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
$`)
var str = `all: whatevs
all:
deps:
$(EXECUTABLE): $(OBJECTS)
$(sort $(a)): $(b) ;
$(a): b
$(a:b=c) : d
$(X:a=b) : w ;
lib/%.o: CFLAGS := -fPIC -g
%.o: CFLAGS := -g
ifneq ($(words $(subst :, ,$(CURDIR))), 1)
hash := $(shell printf '\043')
var := $(shell find . -name "*.c")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}