const regex = /^ # Start of line
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
:(?!=) # Colon NOT followed by an equal-sign
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # Start of line
[^()\\r\\n]* # Any number of non parentheses characters
(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()]*\\))?
[^()\\r\\n]* # Any number of non parentheses characters
:(?!=) # Colon NOT followed by an equal-sign
[^()\\r\\n]* # Any number of non parentheses characters
(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()]*\\))?
[^()\\r\\n]* # Any number of non parentheses characters
$', 'gm')
const str = `all: whatevs
all:
deps:
\$(EXECUTABLE): \$(OBJECTS)
\$(sort \$(a)): \$(b) ;
\$(a): b
\$(a:b=c) : d
\$(X:a=b) : w ;
lib/%.o: CFLAGS := -fPIC -g
%.o: CFLAGS := -g
ifneq (\$(words \$(subst :, ,\$(CURDIR))), 1)
hash := \$(shell printf '\\043')
var := \$(shell find . -name "*.c")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}