import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # Start of line\n"
+ "[^()\\r\\n]* # Any number of non parentheses characters\n"
+ "(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()]*\\))?\n"
+ "[^()\\r\\n]* # Any number of non parentheses characters\n"
+ ":(?!=) # Colon NOT followed by an equal-sign\n"
+ "[^()\\r\\n]* # Any number of non parentheses characters\n"
+ "(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*(?:\\([^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()\\r\\n]*\\))?[^()]*\\))?\n"
+ "[^()\\r\\n]* # Any number of non parentheses characters\n"
+ "$";
final String string = "all: whatevs\n"
+ "all: \n"
+ "deps:\n"
+ "$(EXECUTABLE): $(OBJECTS)\n"
+ "$(sort $(a)): $(b) ;\n"
+ "$(a): b\n"
+ "$(a:b=c) : d\n"
+ "$(X:a=b) : w ;\n"
+ "lib/%.o: CFLAGS := -fPIC -g\n"
+ "%.o: CFLAGS := -g\n"
+ "ifneq ($(words $(subst :, ,$(CURDIR))), 1)\n"
+ "hash := $(shell printf '\\043')\n"
+ "var := $(shell find . -name \"*.c\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}