$re = '/^ # Start of line
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
:(?!=) # Colon NOT followed by an equal-sign
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
$/mx';
$str = 'all: whatevs
all:
deps:
$(EXECUTABLE): $(OBJECTS)
$(sort $(a)): $(b) ;
$(a): b
$(a:b=c) : d
$(X:a=b) : w ;
lib/%.o: CFLAGS := -fPIC -g
%.o: CFLAGS := -g
ifneq ($(words $(subst :, ,$(CURDIR))), 1)
hash := $(shell printf \'\\043\')
var := $(shell find . -name "*.c")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);