// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^ # Start of line
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
:(?!=) # Colon NOT followed by an equal-sign
[^()\r\n]* # Any number of non parentheses characters
(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*(?:\([^()\r\n]*\))?[^()\r\n]*\))?[^()\r\n]*\))?[^()]*\))?
[^()\r\n]* # Any number of non parentheses characters
$").unwrap();
let string = "all: whatevs
all:
deps:
$(EXECUTABLE): $(OBJECTS)
$(sort $(a)): $(b) ;
$(a): b
$(a:b=c) : d
$(X:a=b) : w ;
lib/%.o: CFLAGS := -fPIC -g
%.o: CFLAGS := -g
ifneq ($(words $(subst :, ,$(CURDIR))), 1)
hash := $(shell printf '\\043')
var := $(shell find . -name \"*.c\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}