# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\$((?:(?!\$\$).)*)\$\$/\\($1\\)/g;t' <<< "$$ f'(x) = 12x^2 + 4x $$ $$ f'(x) = 12x+2x-12 $$ $$ f'(x) = 12x^3 +4x^2 $$"