import Foundation
let pattern = #"\$\$((?:(?!\$\$).)*)\$\$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"$$ f'(x) = 12x^2 + 4x $$ $$ f'(x) = 12x+2x-12 $$ $$ f'(x) = 12x^3 +4x^2 $$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\($1\\)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)